Probleme mit dem Widget Bottom Bar

  • Lieber Mario,


    wir haben schon mal wegen des Widget WZP Inforeihe 2.0 kommuniziert.

    meine Zeta-Version lautet: 15.4.1

    mein Layout: Stripe Responsive


    Ich habe mich dann doch für das Widget Bottom Bar entschieden. Nun ist mein Webauftritt fast fertig und ich habe Bottom Bar auf der Eingangsseite installiert und mit allen weiteren Seiten (ca. 100) verknüpft. Das hat auch funktioniert. Ich mußte es allerdings wieder löschen und wollte es neu installieren. Seit diesem Zeitpunkt habe ich seltsame Probleme und kann den Internetauftritt nicht abschließen. Folgender Effekt tritt auf.


    1. Bottom Bar läßt sich zwar in Zeta wieder installieren aber als Resultat klebt ein Mini-Balken im oberen Bereich des Inhaltsbereiches und das nur bei manchen Seiten des Auftritts. Das Widget tritt verstümmelt auf diversen Seiten auf, klebt aber nicht am unteren Rand, wie vorgesehen, es funktioniert also nicht mehr. Irgendwie scheinen mir trotz Deinstallation Reste des Widgets auf Seiten übrig geblieben sein.


    2. Auch wenn Bottom Bar gelöscht ist, so verbleiben noch verstümmelte Bars auf manchen Seiten.


    2. Aufgrund dieses Effektes wollte ich anstelle dessen dein Widget Infoline 2.0 nochmals installieren. Auch dieses ist nun zerschossen und reagiert nicht mehr wie vorgesehen.


    3. ich habe auch das Widget wieder entfernt und in Zeta neu installiert. Irgendwo bleiben immer Reste auf manchen Seiten.


    Leider bin ich ein wenig unter Druck, da der Auftritt nun fertig werden muß. Ich würde mir wünschen, dass ich Bottom Line nochmals neu installieren kann, denn das ist für mich optimal. Leider ist wohl bei der Deinstallation etwas übrig geblieben, dass nun stört. So würde ich das als Laie ausdrücken.


    Hier noch ein Hinweis: Wenn das Widget richtig installiert ist, so wird es beim Srollen von manchen Elementen überlagert und das sieht nicht so optimal aus. Z.B. die Felder meines Kontaktformulares oder auch dein Widget Linkcard 1 überlagern die Bottom Bar.


    Ich würde mich sehr freuen, wenn du mir wieder so schnell und umkompliziert helfen könntest.


    Leider kann ich dir nun keinen Screen-Shot anbieten, würde es aber nachholen. Ich hoffe, ich habe mich halbwegs verständlich ausgedrückt.


    Liebe Grüße


    Robert

    • Das kann ich von hier aus leider schwer nachvollziehen.
    • Wenn du ein bereits eingefügtes Widget wieder deinstallierst (den Widget-Ordner löschst) sollten natürlich vorher im Projekt alle entsprechend eingefügten Widgets entfernt werden, inkl. der Verknüpfungen.
    • Beim löschen des Widgets kann eigentlich auch nichts hängen bleiben.
    • Sollten noch Widgets im Projekt vorhanden sein und das Widget nach dem entfernen neu installiert wurde sollten diese nach einem Extras > Entwickler > Änderungen übernehmen wieder korrekt angezeigt werden.
    • Sollten nach dem deinstallieren eines Widgets noch entsprechende Widgets im Projekt vorhanden sein müssten diese im Spalten-Modus auffindbar sein.
  • Hallo Mario,


    es ist mir nun durch mehrmaliges neu installieren gelungen, die Reste des Widgets aus den einzelnen Seiten zu entfernen. Die Einbindung von Bottom Bar funktioniert aber leider immer noch nicht. Irgendwas mache ich wohl falsch.


    Im Zeta-Producer sieht es zwar richtig aus aber in der Vorschau klebt ein Teil des Buttons entweder im unteren oder oberen Bereich des Inhaltsbereiches.


    Muß man das Widget möglicherweise auf einen bestimmten Ort einer Seite platzieren, um den gewünschten Effekt zu erzielen oder noch bestimmete Einstellungen berücksichtigen?

    Es wäre super, wenn das Widget nicht von anderen inhalten beim Scrollen überlagert wird. (z.B. Formularfelder oder Widget LinkCard)


    Es ist wahrscheinlich nur eine Kleinigkeit aber ich komme an dieser Stelle nicht weiter.


    Ich werde dir gerne das Projekt morgen zusenden, da ich es außer Haus an einem anderen Arbeitsplatz verwalte.

    Ziel ist ein 4spaltiges Widget. Es ist schon auf der Willkommensseite mit den Farben und Fonts angelegt. Und es sollte mit allen Seiten des Auftritts verknüpft werden.


    Liebe Grüße


    Robert

  • Zitat

    es ist mir nun durch mehrmaliges neu installieren gelungen, die Reste des Widgets aus den einzelnen Seiten zu entfernen.

    Das kann ich nicht verstehen, normalerweise sollte ein einmaliges installieren den Inhalt wieder ordnungsgemäß platzieren.



    Zitat

    Muß man das Widget möglicherweise auf einen bestimmten Ort einer Seite platzieren, um den gewünschten Effekt zu erzielen oder noch bestimmete Einstellungen berücksichtigen?

    Nein einfach irgendwo im Inhaltsbereich platzieren, den Rest erledigt das Widget.



    Zitat

    Es wäre super, wenn das Widget nicht von anderen inhalten beim Scrollen überlagert wird. (z.B. Formularfelder oder Widget LinkCard)

    Das kann man einfach durch einen z-Index mit etwas CSS erreichen. Schau ich mir an wenn ich das Projekt habe. Dazu kann ich noch ein Update bringen wo man den z-Index direkt im Widget vergeben kann.



    Zitat

    Ich werde dir gerne das Projekt morgen zusenden, da ich es außer Haus an einem anderen Arbeitsplatz verwalte.

    Schau mir dann an. Nach dem versenden bitte hier kurz bescheid geben. Und die betroffenen Seiten benennen wo das Problem auftritt. Falls es nicht ganz offensichtlich ist kurze Info wo ich das sehe.



    Zitat

    Und es sollte mit allen Seiten des Auftritts verknüpft werden.

    Das ist kein Problem.

    Am besten das Widget auf der Seite System > Vorlage für neue Seiten anlegen. Dann wird automatisch eine Verknüpfung zu neu angelegten Seiten angelegt.

  • Die erste Frage konnte ich schon mit dem "Widget Checker" beantworten. Ist nicht eingefügt.

    Die 2. musst du mir noch beantworten, sonst suche ich mir einen Wolf.


    PS: Irgendwo hast du auch das Widget "Button Icon" eingefügt. Das könnte sich beißen weil ja dort in der Mobilen Ansicht die Icons an der gleichen Stelle platziert werden.

  • Hallo Mario,

    Das Widget dürfte nun gelöscht sein und sollte auf die „Herzlich Willkommen“ Seite neu installiert werden. (4spaltig mit entspr. z-Index, Farben und Fonts würde ich selbst anpassen)

    Die Reste sind nun eliminiert. Das hat diverse Anläufe gebraucht.

    Mir wäre damit geholfen, wenn du das Widget installieren könntest und es in der Vorschau „normal“ funktioniert sowie auch verknüpft mit allen anderen Seiten. Vielleicht hast du ja einen ähnlichen Effekt wie ich.

    Liebe Grüße

    Robert

  • Irgendetwas verhindert in deinem Projekt das die Daten der CSS-Datei gelesen werden können.

    Was das ist und warum habe ich nicht heraus gefunden.


    Folgendes sollte funktionieren.


    Einstellungen > CSS folgendes rein kopieren:



    Anschließend das Widget wie gewohnt einfügen und die Verknüpfungen setzen.




    Wegen dem z-Index müsste ich noch wissen welche Widgets davon betroffen sind und auf welchen Seiten sich diese befinden.

  • Hier nochmal der Code mit z-index. Sollte so funktionieren.

  • Ich habe erst morgen Mittag wieder die Möglichkeit den Code einzufügen. Vielen Dank dafür.


    Z-Index:

    Das passiert bei deiner LinkCard1 sowie bei den Zeita-Formular-Feldern. Ich habe allerdings nicht alle Seiten daraufhin prüfen können, ob weitere Überlagerungen passieren.

    Die LinkCard befindet sich auf den allen Stadtteilseiten (z.B. Mauenheim /Nippes, Ehrenfeld ...), die Formulare nur auf Kontakt und Schadensmeldung.

    Ich wende übrigens auch noch die Laufschrift auf der Willkommensseite an.

  • Lieber Mario,


    genau das ist es, was ich gebraucht habe. So soll es funktionieren, vielen Dank. Ein solcher Support ist ebenfalls vorbildhaft.


    Zusatzfrage:

    Gibt es die Möglichkeit Zeilenumbrüche in der LinkCard1 im Text durchzuführen?


    Liebe Grüße und schönes WE

    Robert

  • Hallo Mario,

    ich hoffe, du bist gut in das Neue Jahr gekommen. Die neue Homepage steht kurz vor der Veröffentlichung. Ich habe noch eine Frage zum Widget Bottom Bar. Hat das integrieren der Awesome Fonts Auswirkungen auf die DSGVO Datenschutzhinweise oder sind die Fonts schon im ZP integriert?

    LG Robert

  • "Font Awesome 4.7.0" ist ab "Zeta Producer 15.4" bereits integriert.


    Die Widgets welche "Font Awesome" verwenden hatten zuvor "Font Awesome 5.0" verwendet. Diese habe ich dann auf "Font Awesome 4.7.0" umgestellt damit "Font Awesome" nicht doppelt eingebunden wird.

  • Hallo Mario,

    ich bin kurz vor der Veröffentlichung der Homepage und möchte nun, wie in deinen Lizenzbedingungen angegeben, den Hinweis erstellen.

    Ist folgendes ok für das Impressum?

    "Urheberhinweis: Es werden Widgets von Mario Groß, http://www.widget-zp.de eingesetzt"


    Weiterhin habe ich noch folgende Anforderung:

    Ich habe eine Landkarte, die als Imagemap fungieren soll. Es sind ca. 10 rechteckige Kästen erforderlich, die anklickbar sein sollen. Du hast ja ein Imagemap Widget aber damit komme ich nicht klar. Sind nur runde Bereiche definierbar und geht die Festlegung der Bereiche auch grafisch?

    LG Robert